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INTRODUCTION TO THE EXCEL SPREADSHEET
Preparing a Gradesheet

LEARNING OUTCOMES
This tutorial will help you understand what a spreadsheet is and where a spreadsheet
might come in useful for classroom management. Specifically you will learn about the
following topics.
• Understanding the basic concepts of a spreadsheet, including:
• the idea of templates
• cells, rows and columns
• cell coordinates
• entering data into a spreadsheet cell
• Setting up labels, including:
• setting column widths
• aligning data in cells
• entering column and row labels
• Creating and copying formulas
• Making changes in a spreadsheet
• inserting rows and columns
• deleting rows and columns
• Producing a printed copy of the contents of a spreadsheet file
• Saving a backup copy of your work
• Appreciating the power of spreadsheet templates
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A caveat before you begin: You'll find it easiest to use the tutorial if you follow
the directions carefully. On computers there are always other ways of doing
things, but if you wander off on your own be sure you know your way back!

3.1

GETTING STARTED

Showing the Full menus
Microsoft Office has a silly habit of showing only a few items in the menus when you
want to use them. If you want to see the full menus, you have to double click on the
menu name, or slide down to the arrows at the bottom of the menu, or, worse still, wait
for the full menu to reveal itself, which it will after a few seconds. But for this tutorial,
we're going to be using quite a few menu items that do not normally appear when you
first click to select a menu. So let's set the Option in Word to Show Full Menus all the
time.
In the Tools menu, select Customize…, then in the dialog box that pops up,
select the Options tab
Remove the check mark next to the item Menus Show Recently Used
Commands First
There, now you'll get the full menus all the time. If you find this tip useful, and
you're working a lab where you can't permanently set defaults like this, remember to
show full menus when you start work using any of the programs in the Office suite
(Word, Excel, PowerPoint, Access, and so forth). If you have your own computer at
home, you might like to permanently set this Show Full menus option. It'll save you no
end of time and annoyance.
Some background
Fig. 3.1 on the next page illustrates a typical school worksheet. As illustrated in Fig. 3.1,
the leftmost column and the topmost row often are reserved for descriptive labels that
identify the value stored in each of the cells in the grid. The rightmost column and
lower rows of a set of figures are often set aside for row and column totals respectively.
In 1978, Dan Bricklin, a young graduate student at the Harvard School of Business,
developed a piece of software called Visicalc which simulated a worksheet. It was the
first electronic spreadsheet, a prototype of the many varieties of spreadsheets available
today.
The Excel spreadsheet is considerably more powerful than Visicalc, able to handle
much larger sets of numerical data at greater speeds. Like Visicalc, however, it goes
beyond the traditional manual worksheet in so far as it is programmable. You can build
instructions into an electronic spreadsheet to do relatively complex mathematical
calculation and analysis.
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Fig. 3.1 Annotated spreadsheet
You also can build instructions into the spreadsheet to carry out humdrum,
repetitive calculations--the kind of calculations which could take hours, even days, to
complete manually but which, when done electronically, take a matter of seconds.
The Excel screen acts as a window onto a large grid of rows and columns into which
data is entered, usually from the keyboard. You can build Formulas into selected cells
which automatically carry out calculations on designated sets of data. You'll learn how
to do that in this lesson.
Practice makes perfect
As with the word processor, the best way to learn about the spreadsheet is to build a
spreadsheet file and work with it. So here goes.
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If you have worked your way through the first two tutorials in this series you will
be very familiar with the steps to take to load a component of the Microsoft Office
software. Go ahead and open Excel. Once Excel is loaded you are ready to complete the
exercises that follow.
You should see a new Excel spreadsheet file titled Book1 (or some such default
name). It is always a good idea to immediately name the file that you are about to
create. The outline version of the file you are about to create will be a template for a
gradebook.1
Put your Data disk in the disk drive, select Save As from the File menu and
switch to the 3 1/2 floppy A: drive
In the Save As dialog box, click on the New folder icon and name the new
folder Spreadsheets
Type GradeTmp as the file name for the new spreadsheet and click on the
Save button
You should now be looking at a screen with the name of your file (GradeTmp) at the
top of a blank worksheet ready for you to insert your data.

3.2

HELPFUL HINTS WHILE USING THE SPREADSHEET

A spreadsheet is a grid divided into columns and rows
The intersection of the column and row is referred to as a cell (Fig. 3.2).

Fig. 3.2 Think of the spreadsheet as a grid divided into rows and columns
1 A template is an outline or form which can be used over and over as a layout when carrying out other
projects that require the same basic file format. Here you are going to build a spreadsheet template to
simulate an empty gradebook. Once you have created the template, you will keep it as a template on
your disk for future use. You will be able to use this template from semester to semester to build the
electronic gradesheets for all your classes.
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Right now, cell A1 is selected in the top left-hand corner of the spreadsheet. This is
where information, in the form of a label, number or formula for calculation, will be
entered. Labels are made up of text that describes the numbers in the columns and
rows. Formulas are mathematical expressions built into certain cells that instruct the
computer to carry out calculations on specified sets of numbers in the rows and
columns. As you go on with the tutorial, these concepts will become clearer to you.
Moving around in the spreadsheet
Table 3.1 lists the effect of pressing the keys listed in the first column.
Keys Pressed

Effect

Tab
Shift-Tab
Arrow keys
Shift-Enter
Enter
Scroll bars

Moves selection to the right to next cell in same row
Moves selection to the left to previous cell in same row
Move selection one cell in any direction
Moves selection up to previous cell in same column
Moves selection down to next cell in same column
Scroll vertically and horizontally through the spreadsheet
Accept button ( ) Accepts data in cell but does not move to another cell
Cancel button (X)
Cancels entry in cell

Table 3.1 Cell selection commands
There are 65536 rows and 256 columns in the Excel spreadsheet. That means there
are over 16 million cells into which you can store data! Usually you’ll use the mouse to
select the cell you want to work in. Just click on the cell to select it. Once in a particular
cell, use the commands in Table 3.1 to proceed to other related cells.
Practice now by moving around the spreadsheet. After you have located several
cells, end up by clicking on cell A1 to make it the current or active cell.
Identifying the active cell's coordinates
Look in the top left hand corner of the Excel screen (Fig. 3.3) to see which cell (the active
cell) you are in at any point in time.

Fig. 3.3 Identifying the address of the cell you are working in
Click on any cell now and look at the cell's coordinates in the top left corner of
the screen
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Each cell address (a location in the spreadsheet) begins with a letter to indicate the
column, followed by a number to indicate the row. For example, H32 identifies the cell
at the intersection of column H, row 32 (Fig. 3.3)
Selecting a range (group) of cells
Table 3.2 lists the methods for selecting a group or range of cells.
Task
To select a block of cells
To select an entire row of cells
(horizontally from left to right)
To select an entire column of cells
(vertically, from top to bottom)
To select several rows or columns

Method
Drag diagonally from top left corner of the block of
cells down to the lower right corner
Click on the number (the row label) on the left hand
side of the spreadsheet
Click in the letter(s) of the alphabet (the column
label) at the top of the column
Drag across the row or column headings

Table 3.2 Selecting a range (group) of cells
Once again, take a few minutes now to try each of these methods for selecting
groups of cells.
Location of the active (selected) cell after entering data into a cell
When you type the data for a cell, the data first appears in the Entry bar at the top of the
screen (Fig. 3.4).
See how this works for yourself now.
Click on any cell and type the number 2000
Look at the Entry bar above the spreadsheet window. The data is displayed there
while you
1. check that it is correct before copying it to the active (selected) cell;
2. make up your mind whether it should be entered into the spreadsheet at all;
3. decide which cell you would like to be the active cell next after the value has
been copied to the currently active cell.

Fig. 3.4 The spreadsheet Entry bar
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You may still decide not to enter the data into the spreadsheet, in which case you
would click on the Cancel box (X) in the Entry bar (Fig. 3.4) and start over. If, on the
other hand, the data is correct, you would click the Accept button ( ), which keeps the
cell you are working in as the active cell.
Click the Accept button (

) now

Notice that the data is immediately copied to the selected (active) cell.
Alternatively, you may want to proceed to the cell immediately to the right of the
active cell into which the number you just typed will go. Or you may want to proceed
to the cell just below the active cell, or the cell just above the active cell, and so on.
A short while back you practiced moving around the spreadsheet using the
commands listed in Table 3.1. This table also lists the key(s) to press to tell Excel which
cell to go to after you accept the data you have typed into the Entry bar.
Practice now by making the cell in which you just typed 2000 the active cell
(by clicking on it)
Then press each of the keys or key combinations in Table 3.1 and verify the
result of the action in the spreadsheet each time
Blanking out a cell or cells in the spreadsheet
The quickest way to blank out cells is to use the Clear option from the Edit menu.
Select the cell holding the data 2000 then, from the Edit menu, select
Clear/All
To do the same to a group of cells you would just drag across the cells to select
them--they will become highlighted. Then select Clear from the Edit menu as before.
Practice now by entering 3 or 4 numbers into adjacent cells in the
spreadsheet, then select all of them and use the Clear command to remove
them in one go
Remember that you can undo the Clear operation (or any other Edit operation) by
immediately selecting Undo Clear from the Edit menu (or press ctrl-Z).
Editing the data in the Entry bar
While you are typing in data in the Entry bar you can edit it as if you are using the Word
word processor. So everything you learned in Lessons 1 and 2 will apply.
Editing data after it has been entered into a cell
If you are past the cell where you have an error and want to make a correction or
change, move back to the cell in question by selecting (clicking on) it. The data in that
cell will be displayed in the Entry bar at the top of the spreadsheet. Click in the Entry
bar (the cursor will show where you clicked on the text) and then just go ahead and
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make any changes you want. Replace the old entry by clicking the Accept button (
by selecting another cell in the spreadsheet.

3.3

) or

SETTING UP LABELS FOR YOUR GRADESHEET TEMPLATE

When you have completed this section and the next section (Sections 3.3 and 3.4) your
gradesheet should look like Fig. 3.5.

Fig. 3.5 Completed Gradesheet Template
The steps that follow will help you achieve this goal. Follow them carefully.
Select cell A2 and type GRADE REPORT
Check the data in the Entry bar to make sure you typed the label correctly;
correct any errors
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Click the Accept button ( ) when you are sure all is well (or press one of the
other keys which accept data into the spreadsheet--arrow keys, Enter/Enter
key, Tab key)
This is an example of a label--which is any text you use to describe the data that is in
a spreadsheet. All the column and row headings are labels also.
You need to widen the A column to allow for longer student last names.
From the Format menu select Column/Width...
Type the number 15 in the dialog box, then click on OK
While you're at it, click anywhere in the B column (first name) and adjust the
width to 12
Later in this section you'll practice adjusting other column widths.
Select cell A4
Type the label Class: (note the colon) and press Enter to move the cell
pointer to cell A5
Type the label Semester: and press Enter to move the cell pointer to cell A6
Finally type the label Year: and click on the Accept button (
bar

) in the Entry

At this point you should be thinking about saving the work you have completed
thus far!
Press ctrl-S to save your work to this point
Aligning data in spreadsheet cells
The gradebook will look best if the three labels you just entered into the spreadsheet
were right aligned in their respective cells. Right aligned means that the label is aligned
to the right side of the cell. Unless you tell Excel otherwise, the system will left align any
data that is regular text (letters of the alphabet, for example). Likewise, the system will
right align any data that is made up of numbers. This makes sense if you look at Fig.
3.6.
Text is usually left justified
on the page, while numbers
are easiest to work with
when they are right justified
Total

23
345
2360
4
_____
2732

Left justified
Right justified

Fig. 3.6 Text is left aligned; numbers are right aligned
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However, sometimes text looks best when it is right aligned in the cell, as should be
the case with the labels you just entered into cells A4, A5, and A6. Here is how you
right align the text in these cells.
Position the spreadsheet tool on cell A4
Hold down the mouse button and drag down to cell A6, so that all three cells
are selected (cell A4 will still be selected even though it is not highlighted--it
has the heavier border which also indicates selection in the spreadsheet)
In the Format tool bar click on the Right Alignment button
This will right align the cells that you have selected (A4 through A6). Check
this on the screen before you go on.
Press ctrl-S to save your work so far (this is a good habit to get into!)
Entering the column and row labels
Now you will enter the labels for each of the columns that eventually will contain the
scores for assignments you might give your students during the course of a school
session.
Select cell D8 and enter the grade label A1 (short for Assignment 1)
Check that you have typed the label correctly, then press the Tab key to
move to the next cell across and enter the assignment label A2
Do the same thing three more times, using the labels A3, A4, and A5 (Your
last entry should be in cell H8)
Click the Accept button (

) next to the entry bar at the top of the screen

These labels might represent homeworks or quizzes for a unit or for a whole
semester, depending on how many assignments you might assess for grading purposes.
When you use this GradeTmp file for an actual gradebook, you will edit these column
labels so that they contain appropriate titles relating to the actual assignments that will
be stored in the respective columns. There is, of course, room in the gradesheet for you
to include as many assignments as you want.
Once you have entered all five of the assignment labels, press the right
arrow key twice; this should bring you to cell J8
Type TOTAL then press the Tab key 2 times to move to cell L8
Type PCNT then press the Tab key 2 times to move to cell N8, then type
GRADE and click the Accept button ( )
Now you will enter the row label for the Maximum Scores.
Select cell C10, type MAX (this row will be used in due course to keep a
record of the maximum score for each assignment, test, and so forth), then
click the Accept button ( )
Finally, you need to enter the column labels for the First and Last names.
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Select cell A12 and type LAST NAME, then click the Tab key to go to cell
B12
Type FIRST NAME, then click the Accept button ( ) and press ctrl-S again
to save your work so far
Entering "dummy" scores
For the sake of the template you will enter a set of "dummy" maximum scores (zeroes).
Later in the tutorial you will edit these Maximum Scores to reflect maximum scores for
actual assignments.
Move to cell D10 and enter the number 0 (zero)
Enter a 0 (zero) for the Maximum Score into each of the remaining
assignment columns (E10 through H10)
Adjusting the width of columns
You will notice that the numbers are not quite lined up under the labels in the
assignment columns. Recall that in Excel the labels (text in general) are aligned on the
left of the column while numbers are always aligned on the right (check Fig. 3.6 if
you're still confused about this).
To improve the appearance to your gradesheet you probably want your column
labels to be more in line with your entries. You already practiced one way of doing this:
namely, to right align the labels. Another way is to reduce the width of the columns
containing scores. They need be no wider than the width of the column labels. By
default Excel makes all the columns about an inch wide (8.43 is the Excel default value
for the column width). Let's change the width of columns C through N so they are only
as wide as necessary.
Click on the arrows at the left or right of the horizontal scroll bar at the bottom
of the screen to scroll the gradesheet over until Column C is at the left edge
of the spreadsheet
Use the mouse to point to the column name "C" at the top of the column (Fig.
3.7)

Fig. 3.7 The Column (letters of the alphabet) and Row (numbers) labels
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Hold down the mouse button, and keep it down, while you drag across the
screen to the right as far as Column H
When you have columns C through H selected, let go of the mouse button
All six columns (C through H) should be highlighted.
From the Format menu select Column/Width...
This will bring up the Column Width dialog box.
Type 4, and click on OK
Now use the horizontal scroll bar to scroll the spreadsheet to the right until
you can see column A again
Changing the alignment of the column labels
It would also be a good idea to change the alignment of the column labels and make
them all center aligned.
Position the mouse over cell D8, then hold down the mouse button, and drag
across to cell H8 before letting go of the mouse button
All the column labels for the 5 assignments should now be highlighted.
In the Format tool bar click on the Center Alignment button
Other columns in your spreadsheet are also wider than necessary. Your tasks now
(Table 3.3) are as follows:
Column
I, K, & M
J and N
L

Width
1
8
10

Table 3.3
Reduce the width of the columns listed in the table to the column width
indicated
Change the alignment of the labels for columns J, L, and N to Center
Aligned
Press ctrl-S again to save your work when you have completed these tasks

3.4

CREATING AND COPYING FORMULAS

Functions and Formulas are powerful tools in spreadsheets which can save you hours
of work.
Functions are routines built into the Excel spreadsheet. Formulas, on the other hand,
are defined by the user, and may include the built-in functions. Both functions and
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formulas accomplish the same task: they tell Excel to do some kind of calculation for
you.
For example, at the end of a semester you will want to calculate a total point value,
and probably a percentage, for each student. To do this you can program the
spreadsheet to do the work on the values in appropriate cells. You can have the
spreadsheet add up the numbers in a whole range of cells, or have it tell you the
average score in a range of cells, and so on. You can also have the system copy a
formula into other cells. Let's try a few things along these lines now.
Creating the formula
Let's enter a formula and see what it does.
Select cell J10
Type =SUM(D10:H10) then click the Accept button (

)

The "=" symbol at the beginning is a clue to the system that what follows is a
formula. So remember this:
ALL SPREADSHEET FORMULAS BEGIN WITH THE "=" SIGN.
The formula =SUM(D10:H10) tells Excel to sum (add together) the scores entered in
cells D10 through H10 and store the result in cell J10, J10 being the selected cell in
which you want the formula to do its job. SUM is one of many Excel built-in functions.
It automatically carries out the series of additions to produce the required result.
We’ll look at the built-in functions in a moment.
Notice the 0 (zero) that now appears in cell J10. This number is the sum of the zeroes
you typed in cells D10 through H10.
In a short while you will have an opportunity to test whether the formula is correct.
You will be entering into the spreadsheet a maximum score for real assignments along
with a set of scores for a roster of students.
For now, if you typed in the formula correctly and clicked the Accept button ( )
you should see that J10 contains the sum of all the maximum scores (which for the time
being is 0 (zero), of course).
Press ctrl-S again to save your work so far
Copying and pasting formulas
Soon you will be entering a set of data for several students. But first you must complete
the GradeTmp by creating a formula that will produce a total or sum of the eventual
scores for each student.
Before you carry out the exercise, here is a description of what is involved. Fig. 3.8
on the next page illustrates the process.
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You are going to copy the formula from cell J10 to the relevant cells in the same
TOTAL column. You will start by copying the formula to the clipboard. Then you will
paste it into the first of the cells where you want the formula duplicated. Finally you
will tell Excel to "fill down" a copy of the formula to the remainder of the relevant cells
in the column--one for each student in the roster.
Copying the formula...
Select cell J10 if it is not still selected from the previous exercise
Press ctrl-C for copy (or, from the Edit menu select Copy)
The formula in cell J10 has been copied to the clipboard in the computer's primary
memory. Think of the clipboard as a temporary holding area for a single set of data.
Once something is on the clipboard it can be pasted anywhere else--in this spreadsheet,
or in another spreadsheet, or into some other file.
Spreadsheet cell before
cut & paste process

Document after
cut & paste process

=sum(D10..H10)

=sum(D10..H10)

=sum(D14..H14)
=sum(D15..H15)

CUT

PASTE

data from one or
more cells in the
Spreadsheet to
the clipboard

data from the clipboard
to another cell or other
cells in the
Spreadsheet
(or to another document
altogether)

=sum(D10..H10

Clipboard

Fig. 3.8 Copying and Pasting
Pasting the formula...
Row 14 is where you will enter the first student's name and scores when you create an
actual gradesheet after you have saved this template. So you are going to paste the
formula you just copied (you copied it from cell J10) into cell J14.
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Select cell J14
Press ctrl-V (this is the short cut command for selecting Paste from the Edit
menu)
Look at cell J14. You should see the value 0 (zero) stored there. Now look at the data
in the Entry bar at the top of the spreadsheet. Interesting! The formula is different from
the one you copied from cell J10.
Check this out--click on cell J10 again
Notice that the range of cells is D10 through H10.
Now click on cell J14 again
The range of cells is D14 through H14. So Excel automatically adjusted the range so
that it would make sense in row 14 (where the first student's scores will be). This is
called Relative referencing.
Relative references
You might find this a trifle tricky to follow, so put on your thinking cap! The system is
copying the formula in cell J10 to cell J14 in relation to ("relative to") cell J10. In other
words, just as the formula in J10 sums the values stored in cells D10 through H10, so the
formula copied to cell J14 will sum the values relative to cells D14 through H14.
Does that make sense to you? If so, give yourself a pat on the back! If not, don't
despair. Read 005 ver a couple of times. The alternative to a Relative Reference, by the
way, is an Absolute Reference. You will need to use an Absolute Reference shortly, at
which time you will more easily understand what 005means in the context of the
exercise. Bet you can't wa005to check 005 ut!
Press ctrl-S again5to save your work so far (are you getting into the habit of
doing this?)
Filling down (copying the formula into the rest of the TOTAL column)
Excel prov0des a neat tool to duplicate the contents of cells into a set of adjacent cells.
For the sake of this exercise we will assume you will have just ten students in your
class. You are going to duplicate the formula that is in cell J14 into the other nine cells
below it. As before, Excel will automatically adjust the cell addresses so that they are
appropriate (relative) to each student's record.
Select cell J14, if it is not already selected
Use the mouse button5to drag down5to highlight all the cells from cellJ14 to
cell J23
Notice that the set of cells from J14 through J23 are now selected as a block on the
screen.
From the Edit5menu selectFill/Down (ctrl-D for short)
This command copies the formula down5to the end of the selected set of cells. For
now, a zero will appear in each cell of the TOTAL column (Fig. 3.9).
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This is because you have not yet entered any scores. Later, when you do enter the
scores, the current total for each student will appear in the TOTAL column.
Press ctrl-S again
Setting up the Percentage formula
The next formula you need will go in the PCNT column (column L) and will calculate
the percentage for each student. The formula will tell Excel to divide the Total Points
earned by a particular student by the Total of all the Maximum Scores for each
assignment.
Select cell L14, since this is the cell in the PCNT column for the first student
The formula you want will divide the value in cell J14 (which is the Total points for
the first student) by the value in cell J10 (which is the Total maximum score possible).
Type the formula =J14/J10 and press Enter

Fig. 3.9 "A zero will appear in each cell of the TOTAL column."
Error messages are sometimes OK
Uh, uh... The entry #DIV/0! is displayed in cell L14. This is an error message warning
you that the formula in cell L14 is telling Excel to divide by zero (the current value in
J10)--an illegal operation because it is undefined in math.
In one sense, you don't need to worry about this for now. You will eventually have a
value other than zero in cell J10 when you put actual Maximum scores into the
Gradesheet and this will take care of the #DIV/0! message. But the error message,
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because it does not use the word "error" in the message, might be disconcerting to
someone who does not understand what is going on.
This might be the case if, for example, you were to share your template with a
colleague at your own or another school.
Using Logical functions
Excel has a useful built-in function for dealing with errors such as this. It's the logical IF
function. The whole function looks like this: =IF(Logic expression, Value if True, Value
if False). Actually, Excel has over 100 functions divided into nine categories. Let’s look
at all the built-in functions now so that you can know how to find them when you need
them.
From the Insert menu select Function...
The Paste Function dialog box appears on the screen (Fig. 3.10).

Fig. 3.10 Paste Function dialog box
Click on the Logical category in the Function category: box and look at the
set of 6 Logical functions which appear in the box to the right
Notice the IF logical function—the third one listed in the Function Name: area of the
dialog box.
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Click to select the IF Function now, and notice that the components of the IF
function are displayed below the Function category box in the dialog box
(Fig. 3.10 again)
The Logical test part of the expression is a statement which the spreadsheet will
evaluate as either true or false. For example 2+2=5 will be evaluated as false; 2+2=4 will
be evaluated as true. The second part of the Logical IF expression (value_if_true) is
what you want the spreadsheet to put in the cell if the Logical expression is true. The
third part of the Logical IF expression (value_if_false) is what you want the spreadsheet
to put in the cell if the Logical expression is false.
Try the following example for practice. It will be easier to begin with if you just type
in the formula yourself instead of using the built-in function provided by Excel. Built-in
functions are really useful when you know what you’re doing, as you will soon enough.
But let’s keep it simple for now.
Close the Paste Function dialog box by clicking on the Cancel button
Click in cell A30 and type the formula:
=IF(2+2=5,"How can that be True!","Of course it's False!")
Click on the check mark (_) to accept the formula into cell A30
We know that 2+2=5 is False, so the result that will be displayed in cell A30 will be
"Of course it's False!". Notice, by the way, that you can have text as the result; it doesn't
have to be a number.
Select Clear from the Edit menu to remove the formula from cell A30
Back to the Division by zero problem
OK, in cell L14 you want to tell Excel that if the value in cell J10 is zero (0), it should put a
phrase such as "Div/0 error" in cell L14. This will better explain what is going on. It will
also remind you that those Maximum Scores need to be updated before the spreadsheet
will work with an actual class of students. You will also tell Excel in cell L14 what to do
if the value in cell J10 is other than zero (0)--which it will be if there are Maximum Scores
other than zero. In this case, you will tell Excel to go ahead and calculate the percentage for
the student.
Now, how would you write that as a formula? If you think you can figure it out (and
you'll impress your instructor no end if you can!), write down the correct formula in the
box below:

…………………………………………………………………………………………
The answer is....(drum roll...)
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=IF(J10=0,"Div/0 error",J14/J10)
Go ahead and type this formula into cell L14 now
Absolute references
You need to make one small change to the formula in cell L14 before you copy it to each
of the cells from L15 through L23. This is because part of the formula needs to be an
Absolute Reference.
Look at the formula again:
=IF(J10=0," Div/0 error",J14/J10)
Cell J10 contains the total of the maximum scores. The percentage for every student is
calculated by using the value in this specific location. So the reference to this cell must not
change when the formula is copied to the other cells in column J. This is why it is called
an Absolute Reference--it must not change; it must always reference cell J10. The value
in J14, on the other hand, is relative to the student data in row 14. This reference (to cell
J14) will change relative to each student.
Does that make sense? Read the previous paragraph over again if you need to. The
fact is that you must tell Excel that you want any references to J10 in the formula
specified for cell L14 to be Absolute, otherwise the formula will not copy correctly to
the other cells in column J.
Follow these steps to do this.
Select cell L14
Look at the Entry bar. You should see the formula =IF(J10=0,–Div/0 error",J14/J10).
Position the cursor immediately after the first parenthesis in the Entry bar
Type a dollar sign ($) before the letter J, and another dollar sign ($) before
the number 10 (so the formula will now be =IF($J$10=0,"Div/0
error",J14/J10))
Look at the formula again. Do you see the second reference to cell J10 at the other
end of the formula (J14/J10)? You're going to need $ signs there, too.
Go ahead and fill them in (J14/$J$10) just as you did at the beginning of the
formula
The $ signs tell Excel to treat the reference to column J and row 10 as Absolute when
copying the formula to other cells. The reference to J14, on the other hand, will be
Relative and will therefore change relative to whichever cell it is copied to, so there's no
need for dollar signs here. Remember:
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A dollar sign ($) before each part of a spreadsheet cell address tells Excel to
treat the reference to the cell as an absolute (unchanging) reference.
Phew! That's the tough part over with.
Click on Accept (
change

) to accept the formula, then press ctrl-S to save the

Now that you have edited the formula, you want to copy it to the other cells in the
PCNT column.
Cell L14 should still be selected, so use the mouse to drag down from cell
L14 to cell L23, then from the Edit menu select Fill/Down
Voil?! All the appropriate cells have been set to calculate the percentage for every
student once you have entered a set of scores for each student. Right now, remember,
you have the "Div/0 error" message in each cell because you are telling Excel to divide
by zero. As you know, this problem will be overcome when you enter an actual set of
maximum scores into row 10.
Press ctrl-S again to save your work so far
Notice that you are doing all the hard work up front. Once you have built the
template, using it as a gradesheet will be easy--as you will see in a moment. You have a
few more tasks to complete before the Gradesheet is ready, however.
Setting the Cell Attribute for the PCNT column
When you divide one number by another the result is usually a fraction. Thus the
eventual percentage for each student won't look like percentages at all. Instead of, say,
85%, the computer will display 0.85. It would be best to display the percentages as
whole numbers (no fractions) with a % sign after them. So you must add this feature to
the Gradesheet template.
Follow these steps to format (select attributes for) the values in the PCNT column so
they will eventually display as recognizable percentages.
If necessary, drag the mouse from cell L14 to cell L23 and, in the Format
menu, select Cells...
In the Format cells dialog box, from the Category menu select Percentage
Then click on OK because the number of places after the decimal point
(called Precision) is set at the default of two (2)
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That's it. Later, when you add students and their scores to your roster you will see
all the percentages displayed with the % sign. You are now ready to save your template
for the last time (ctrl-S).
Checking out the formulas
It will be useful for you to know how to verify that the formulas are in place in the
spreadsheet. Follow these steps to do this.
From the Tools menu select Options..., then in the Options dialog box (Fig.
3.11) put a check mark in the box next to Formulas, and click OK

Fig. 3.11 Showing or not showing formulas in the Options dialog box
This will display all the formulas in your spreadsheet. Excel widens the columns so
you can see the whole of each formula.
Scroll over if necessary to check out the formulas displayed in columns J and L
After you have verified that the formulas are stored correctly relative to each of the
appropriate cells, you should return the display to show the values in the cells.
From the Tools menu select Options again, click in the box next to
Formulas to deselect it, then click on OK
Notice that the formulas are hidden once again and the columns are restored to their
original width. The last summary column in the spreadsheet (column N) is for the final
letter grade. For the purposes of this tutorial, you will enter the grade yourself based on
the totals, averages, and other factors that you consider significant in assessing the
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quality of your students' work. Thus, no formula will be supplied for this column at this
time. Later, in Lesson 4, you will learn how to create a Lookup table so that Excel can
assess each student's grade and enter it into the spreadsheet. This will simplify your
work still more.

3.5

ENTERING NAMES AND SCORES FOR EACH STUDENT

Changing the name of the template file (GradeTmp)
Now that the template is safely saved on disk, you can start to use it to build specific
gradesheets for particular classes.
As you can see, the template is still on the computer screen after you have saved a
copy of it on your disk. You are going to fill it out with student names and scores. The
template will no longer be a template; it will be an actual grade roster. Therefore, the
first thing you must do is change its name, so that when you save the file it will not
overwrite the template that you want to keep for future use. It is always a good idea to
do this straight away because you might forget to do it later.
Up until now you have been working with the file that you originally called
"GradeTmp." Let's say you are a 4th Grade teacher, and the year is 2000. A good file
name for this gradesheet would be Grade4 2000.
You probably remember how to change a file name from the previous two tutorials.
But in case you don't...
Select Save As from the File menu and type the name Grade4 2000, then
click on Save
The new filename will appear at the top of the screen. You should start by filling in
the specific class and semester details for the new gradesheet.
In cell B4 type Grade 4, hit the Enter key, type 1 for the semester, hit Enter
again, then type 2000 for the year and click on Accept ( )
Entering the student names
Now select cell A14 (this is where the first student's last name will go)
Type a student's Last Name and hit the Tab key to move to cell B14
Type the student's First Name
Hit Enter, then the left arrow key, to move to cell A15, and do the same for
the next student
Repeat these steps until you have a roster of 10 students. Notice how the names are
all lined up on the left of the column (text is normally left aligned). It doesn't matter if
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your names are not in alphabetical order at this time since Excel lets you sort them any
time you like, as you will learn later in Lesson 4.
Entering the scores for each student
Your next step will be to enter scores for these students. But before you do this you will
need to decide what kind of scores they will be--Homeworks, Tests, Quizzes, and so
forth.
Select cell D8, and type a brief label in the Entry bar, such as HW1, or
Test1, and press the Tab key
Do the same for each of the four other labels for the scores columns. Next you must
decide what maximum scores you want for each assignment.
Select cell D10
Type a maximum score for the assignment or test recorded in this column
(column D)--a maximum score is the highest possible score that can be
achieved for the assignment or test (such as 20 out of 20, or 100 out of a
possible 100, and so on)
Move to each of the other four maximum score cells (E10 through H10) and
enter appropriate maximum scores
Now look across to column L
Notice that those warning messages in column L have gone. This is because you are
no longer telling Excel to divide by zero (cell J10 now has a value other than 0 (zero) in
it).
Next, select D14
This is the first cell in the first column of scores for your students. Type a score for
each student (press Enter after each score because you want to go down to cell D23).
Remember that the score should be within the Maximum Score range for that HW, Test,
Worksheet, or whatever.
Now enter scores for each student in each of the remaining four Assignment
categories. If you move across to columns J and L, you should notice how the Totals
and Percentages are all kept up to date as you enter each score and the percentages look
like percentages! If the columns are filled with ###### signs, this is because the column
is not wide enough to show the data. Go ahead and make the columns wider if you
need to.
This is where you begin to appreciate the power of the formulas that you have built
into the gradesheet template. You don't need a calculator any more. The spreadsheet is
your calculator.
Once again, you must save your work (press ctrl-S)
Everything will be saved under the new name (Grade4 2000) on your Data disk.
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3.6

MAKING CHANGES TO YOUR GRADESHEET

Now that your gradesheet is complete and saved on your disk, this does not mean that
you cannot make alterations to it. Perhaps a new student needs to be entered onto your
roster, or you have accidentally overlooked an assignment and want to enter it into
your gradesheet, or you decide to add an extra assignment or test to your normal
schedule. This can all be done with little effort on your part.
Adding a student to the roster (Inserting rows)
A new student can be added by inserting a row. To insert a row you would select the
location ahead of which you want to place the new row or rows (say before Row 16).
Excel inserts a new row immediately ahead of the row you have selected. Follow these
steps to try this now.
Select row 16 by clicking in the row label (the number 16 at the left edge of
the spreadsheet--Fig. 3.12)
Row 16 will become highlighted on the screen.
From the Insert menu select Rows
You should now see a new empty row. If you inserted the row in the wrong place,
remember that you can undo what you just did by selecting Undo Insert from the Edit
menu.
Now you must fill the new row with data as in the rest of the spreadsheet.

Click on the
row number 16

Fig. 3.12 Selecting a row
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Make cell A16 the active cell now and fill out a name and a set of scores
You will also need to copy the math formulas from cells J10 and L14 to the
respective cells in the TOTAL and PCNT columns.
Move, first, to cell J10 and press ctrl-C (the shortcut for the Copy command)
Move to cell J16 and press ctrl-V (or select Paste from the Edit menu)
Now follow the same procedure to copy the formula from cell L14 to cell L16. After
you have copied the formulas you should check to see that the results in the various
cells make sense. Mistakes are always possible.
NEVER ASSUME THAT THE COMPUTER IS GIVING YOU THE
CORRECT DATA. IT'S ONLY AS GOOD AS THE PERSON WHO
PROGRAMMED IT--AND THAT PERSON IS HUMAN!
Inserting columns
To insert a new column, you will select where you want to insert the column--say
between columns F and G. Excel will insert the new column(s) to the left of the column
you select.
Select column G by clicking in the column label (the letter "G" at the top of
column G in the spreadsheet)
Column G will become highlighted.
From the Insert menu select Columns
Excel inserts an empty column to allow you to enter a new set of data. The column
width is set to be the same as the column next to which it is inserted.
Again you will need to fill in a column label in cell G8, a maximum score for that
assignment (in cell G10), and a set of actual scores, one for each student in the class.
Notice that the column label you enter in cell G8 is right aligned since you set this
attribute across the cells from D8 to H8. Notice, also, once more that all your totals and
percentages are updated to reflect the new set of scores.
Deleting (cutting) rows and columns
Here are the steps to delete rows or columns from a spreadsheet.
Select a row or column, or a set of rows or columns, by highlighting them,
then, from the Edit menu select Delete
No need to practice this now. Just remember where to find this section if you ever
need to delete rows or columns from a spreadsheet.
The beauty of an electronic spreadsheet such as Excel is that, even when you add or
delete rows or columns, the system automatically updates the formulas where
appropriate to match the new state of the data. If you make changes like this that you
want to keep, you must save your work once again. Do this now.
Save your gradesheet file
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3.7

PRINTING YOUR GRADESHEET

You are now going to print a "hard copy" of your gradesheet. Unless you decide
otherwise, Excel will print on the page in the Portrait orientation (Fig. 3.13).

Fig. 3.13 Portrait and Landscape page orientation
If your gradesheet is too wide to fit on the 8.5 inch width of standard paper, you can
print the gradesheet sideways (Landscape orientation).
From the File menu select Page Setup to bring up the dialog box (Fig. 3.14)

Fig. 3.14 Annotated Page Setup dialog box

Lesson 3: Introduction to the Spreadsheet

93

Click on the radio button next to Landscape, then click on OK
In the Page Setup dialog box you can also tell Excel to print or not to print gridlines,
row and column headings and so forth. You can thus still make changes to the
appearance of your spreadsheet on the printed page.
Click on the Sheet tab in the Page Setup dialog box, then check to see if
there is a checkmark in the box next to Row and Column Headings (remove
the check mark if necessary)
This is to tell Excel you do not want those headings in the printout.
Now click on the Print button to bring up the Print dialog box (Fig. 3.15)

Fig. 3.15 The Print dialog box
In the print dialog box, choose the number of copies you would like. As a rule, it is
best to have the computer print only one copy, since it easier to make multiple copies by
using a photocopier. Also, if you have the option, select draft quality the first time or
two, so you don't waste ink (this is an option on dot matrix, daisy wheel, or ink jet
printers, though not on laser printers).
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Another tip, if you have control over your own printer, is to recycle once used paper
(clean on one side) for draft copies. You might even start collecting this, instead of
throwing it away. Help save the planet!
For Print Range in the Print dialog box the radio button for All is selected by
default. If you look a little lower in the dialog box (in the Print what section) you’ll see
that the radio button for Active sheet(s) is also selected by default. These are the correct
settings for this tutorial. We’ll check out other options in Lesson 4.
Finally, select Print
The printer will print your gradesheet so you can hand it in to your instructor.

3.8

SAVING A BACKUP COPY OF YOUR WORK

Your last task before completing this session at the computer is to make a backup of
your spreadsheets on another disk. The GradeTmp and Grade4 2000 spreadsheets are
saved on your Data disk, which is in the disk drive.
Close the Excel spreadsheet program
Close or minimize any other windows that may be open on your desktop to
make it easier for you to see what you’re doing
Double click to open the My Computer icon, then double click on 3 1/2
floppy A:
Now drag the folder Spreadsheets from your Data disk to the Desktop and
drop it there
Watch while Windows makes a copy of your files on to the desktop, then
close the Window on your Data disk
Remove your Data disk from the disk drive, replace it with your DataBkp disk
and double click on 3 1/2 floppy A:
Now drag the Spreadsheets folder from the desktop to your DataBkp disk

3.9

A WORD ABOUT TEMPLATES AND STATIONERY DOCUMENTS

In the two previous lessons, and in this lesson, you have been introduced to the concept
and importance of templates. So much of a professional's work is based on standard
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You should think "Template" whenever you use Microsoft Office. "How can I
leverage the effort I'm putting into creating this document? Are there parts of it that are
common to other documents I have to produce? Is there a template here that I should be
saving as a separate file for future use?"
Office uses the term "Stationery" to describe documents that act as templates for
word processing, database, spreadsheet, or Presentation applications. A selection of
some two dozen "starter" documents are supplied with the software. Over the course of
your career you will undoubtedly develop your own set of stationery documents or
templates.
The rationale behind templates is personal productivity, where time and ideas are at
a premium. Templates are a powerful way of capturing the free flow of ideas in the
form of electronic files which enhance the quality and efficiency of our work.

LOOKING BACK
As you must be aware, there is still a great deal to learn about the Excel spreadsheet, but
you are on your way.
This should be enough to give you ideas about using the Excel spreadsheet to keep
records of numerical data. Apart from finding out what a spreadsheet is, you have
learned how to build a spreadsheet template, including labels and formulas. This
included basic layout operations such as expanding the width of selected columns and
aligning cells. You also learned how to copy formulas to other cells in the spreadsheet.
You then learned how to change the name of the spreadsheet so that the template
could be kept unaltered for later use.
After you filled out the gradesheet and saved the set of data for a class, you
practiced making changes such as adding or deleting rows and columns, and changing
the value format for certain cells to percentages.
Finally, you learned how to print out the entire spreadsheet. This latter function is
not something you would do as a matter of course. You might well, however, print out
charts based on a spreadsheet in order to include them in a report that you have
developed using the word processor. You’ll learn how to do this in Lesson 5.

LOOKING FORWARD
The next spreadsheet tutorial will help you learn other important aspects of working
with spreadsheets, such as using the Lookup function and creating charts of various
kinds.
You are probably becoming familiar by now with the environment called Microsoft
Office. As you have no doubt noticed, skills learned using the word processor carry over
into the use of the spreadsheet or the database. This is the most important advantage of
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an integrated software package such as Office. It means that the learning curve is less
steep.
You will find that completing the remainder of these tutorials will not be nearly as
tough. If you found the first three lessons easy, so much the better.

SKILL CONSOLIDATION
Complete as many of these exercises as you can to reinforce what you have learned in
Lesson 3.
1. Update Grade4 2000 by adding an extra column for another assignment, quiz,
project, or test score and hand in your printout of the new spreadsheet.
2. Add two students, along with their scores for all assignment categories, to the
gradesheet that you created using this tutorial. Copy the formulas where necessary.
3. Add an extra column for another assignment (HW, Test, etc.), add a student, and
update the summary (totals, percentage) columns where appropriate. Update the
calendar data in the top left corner of the spreadsheet for a class taking place in the
Fall semester, session 1, 2000.
4. Design and create a spreadsheet to handle an income statement for your personal
checking account. The income statement will span one full year, from January to
December. The leftmost column will contain a list of items that you typically
purchase during the course of a month. Then the column headers across the
spreadsheet will refer to months in the year. The numbers in the cells will be the
financial amounts that you spent on each item per month. Then you will include
totals at the bottom of each column (a tally for the month) and totals for each item at
the end of each quarter/year. This could become an ambitious group project if you
were to add extra features such as weekly data with break points (sub totals) and so
forth--very useful, too.

